# FLUX Studio 0.3.19 Change log + Delta Firmware / Toolhead


#21

I’m on MacOS and had the same error this morning. Last nights print finished just fine, but error message from FS when computer woke from sleep. No completion message.

I was printing a duplicate so I clicked Start again anyway and the Delta fired right up and started printing.

It seems the problem is related to when computer goes into sleep mode, messages to/from Delta & FS are lost. When connection is woken again those errors pop up but the Delta & FS reconnect. Any messages are gone. Not sure what protocol is used between the two but it seems like no ACKnowledge is used and messages aren’t queued.


#22

@BoozeKashi There are a lot to look into when the computer woke from sleep, web socket reconnection and state of the machine. We’ll continue to work on it.


#23

Thanks @proclaim. Yes I know there’s a lot going on with both ends of the connection, and both devices going through sleep/wake cycles. It seems to correct itself and things work out fine, just reporting it so it can be looked at later.

Currently more concerned about heat break tube issues and nozzle threads leaking (ticket open, no response yet), as well as being able to order spare parts :slight_smile:


#24

@proclaim
Printing is finished overnight, PC wakes up and FS is disconnected and can’t recovered Wifi connection. Previous version can recovered Wifi connection after few try like reload app. Release and renew IP is help.
Printing is still in finished task and double click on Flux button to set to Idle mode. However, these existing bugs on earlier version as well.
Wifi connection is unreliable on 0.3.19 which compare to previous version. I have to use IP release/renew for a second time to get into SD folder.


#25

@proclaim
Hello,

So when will you be releasing the new head for the printer, and any hints on what it will be?


#26

@BoozeKashi, if the nozzle is not properly tightened against the steel heatbreak sleeve, it will leak from the top and/or bottom of the heater block. With my old 3D printer, I had a leak from the threads after a nozzle change. Although I thought I put plenty force, the replacement nozzle was not tight enough. Maybe that is also your case.


#27

@mc_ott, I thought about that, but it leaked the first time from the OEM factory produced toolhead. Maybe that was defective or improperly assembled. After I cleaned it all up (and after many good prints later) it failed again, I too thought I had plenty of torque applied when I replaced it. Maybe it’s just a bad head? Maybe it loosens over time? I’m not certain what is really happening. Support is sending out a new head, and I live not very far from there so will look it over thoroughly and keep a close eye on it in the future.

It does have me wondering about any difference in thermal expansion effect between the aluminum and the brass nozzle, and maybe it works itself loose just enough to ooze over time. Certainly there was enough gap between the nozzle and the heatbreak sleeve for damage to occur to the end of the PTFE sleeve. But it also looks like if it was really torqued down too hard, that could crush that tube end.

Maybe it is just my toolhead, but when I put a bit of force on tightening the nozzle, the hotend flexes inside the holder a little. That was the point at which I stopped applying any more force. The nozzle was nearly flush in the head, (within microns) so it seemed like enough, and I didn’t want to overtighten as it felt like the whole hotend assembly could spin inside the toolhead.

I’ve seen some very sexy aftermarket hotends, but they all are designed for a more open assembly. I don’t think the Flux toolhead/hotend combo is that much different other than being enclosed. I’m just waiting for someone braver/more skilled than I am to come up with a retrofit plan.


#28

I am also unable to get FLUX Studio 0.3.19 to work on ubuntu 16.04 (64-bit).


#29

Filament unload and load still not working…


#30

@proclaim, you state that the Delta Firmware 1.3b2 now supports hidden SSID…just tried it and it doesn’t work. Flux Delta still not connecting to my hidden SSID and I have to unhide it to connect.


#31

just to update you with the progress, there is a file casing problem that’s causing ubuntu build fail. We’ve corrected the issue and will push the release to 0.4.

the scheduled release of 0.4.0 is the end of this month (if all goes weel, we’re currently in QA phase).


#32

the hidden SSID is still not yet working is because the firmware is supporting that function, but flux-studio is not yet implemented. I apologize for the confusion because there was a miscommunication. This feature will be working on v0.4.0.