Flux Studio 0.3.16 Bug Report


#1

@proclaim

  1. After waking up PC from sleep and Flux Studio is opened in a morning, started load filament and connection error message when I clicked on “Next” on loading filament. Click OK to close the message. FS went back to load filament dialog box. Clicked “Next” and it worked.

  1. Then I uploaded gcode file and started on printing. Calibration was once in a center plate and WOW!!! it printed on mid air at 170C, which was a temp at calibration; it should be at 215C for a skirt and first layer. I aborted a print and went back to S3D to review settings and gcode file; everything were correct. Here is link of printing in mid air.
    https://www.dropbox.com/s/e4pmh0n24bzkfn6/20160723_025931000_iOS.MOV?dl=0
  2. Next step, I did manual calibration and it did three points calibration. Then I started on printing again and WOW!!! it repeated again as same as steps above. Restart FS and it still did a same thing, print on mid air at 170C.
  3. Power cycle a printer. Generated gcode and reviewed it. Deleted old file on SD card and uploaded a new gcode to SD folder and started printing and it is printing normally. :grinning::sweat_smile::joy:
    @proclaim Can you explain it to me what’s happened? Every time I’m testing a new Flux Studio version and it likes to open a Pandora’s box.
  4. Here is another error message and clicked retry then it’s OK.
  5. Quick Fix on “ranout of filament” error.

#2

Same problem here… first few small test prints with the new version worked fine and then it happened.
After power cyling the printer I could not even reconnect to it…

Went back to 0.3.10 same thing… seriously wtf guys… do some QA.

Update: well 0.3.10 decided to connect again but still please test your software in house @proclaim
Recent software issues and the firmware bricking issue make me very hesitant now to even try new versions.


#3

Use command line to run “ipconfig /release & ipconfig /renew”. It works for me when I first run FS 0.3.16 and when it doesn’t see a printer.


#4

@proclaim
This is a second time I have to use “ipconfig /release & ipconfig /renew” to reconnect to a printer. Are some new changes on wifi connection protocol?
Also @Simon claim that I can import gcode file from third party slicer and print from FS 0.3.16 without uploading directly to SD folder and print from there, it doesn’t work on when using import.