Can one load more filament when current roll runs out


#1

I was about 8 hrs into a 21 hour print and I noticed that I was going to run out of filament. That was my own fault - should have paid attention to how much was left vs. the estimated amount for the print.

Would there had been a way to add more filament (assuming I had more of the same color :blush:)?
Has anyone done this before? If so, could you post your process/procedure in how you added the filament?

I did notice that when the Flux detected the end of the filament, it retracted a lot of the filament. I’m guessing that I could have just removed what was retracted (making sure no little blobs of filament was left in the tube feeding to the print head) and then just pushed in filament from a different roll. If anyone has done this, please explain how you did it.

Got to order more filament now :sob:


#2

I have done exactly what you described. However, I knew I was going to run out of filament, so waited for the printer to detect no filament, and immediately pulled the leftover of the filament out and poked the next roll in while it was still nice and hot! :wink: It been a while now… but if the head parks itself to the side, I’d heat the head up again (through the Machine -> Set temperature option) if you can, and then push the new filament through, clean the tip, and unpause. Else you’re going to have issues if that head has cool down with the filament not pushing through! :open_mouth:


#3

Thanks for the reply. I kind of thought that was the process, and was looking for someone with some experience to share. After I cancelled the print I then thought that I could have done what you explained, even using a different color.
I’ll try again with a different test print until I feel comfortable in doing it…for the next time I run out of filament during a big print. :wink:


#4

Yeah, that’s basically how I did a multicolour print one time… just paused it on the dashboard, and then ran up and changed the filament, and set it off again. I didn’t do the fancier bit of actually check which layer it should print to, and then have the machine automatically pause at that layer :wink:


#5

I just did a test and this is the process for those interested (I did this with FS 0.8.3, flux firmware 1.6.75, printhead firmware 1.2.18):

  • Once FS filament sensor senses that you are at the end of the filament roll, it will stop the print and retract what is in the tube leading to the print head.
  • Once this is done, press down on the filament latch and remove the left over filament.
  • Select the following from the menu:
    Machines > choose your device > Change Printing Material > Load Filament
  • As the stepper motor starts to turn, gently push the new filament in the filament feed hole (no need to push down on the latch - the stepper motor should get a grip of the filament and push it in).
    NOTE: If you apply slight pressure to the build plate, the motor will speed up and the filament will travel quicker down the tube to the print head.
  • Once it is inside the print head and you see filament coming out the nozzle, press the FLUX button (on the printer) to finish loading (NOTE: you will want to remove any excess filament coming out of the nozzle before you do the next step).
  • Double press/click the FLUX button to resume the print.

#6

When I load filament, I usually push the filament latch down and feed the filament all the way into the print head before I select the ‘load filament’. I tried to do this but the stepper motor was engaged and I could not get the filament to feed in. This is why I say to select the ‘load filament’ and then feed the filament in as the stepper motor starts to turn.


#7

I’m curious… why do you say it was engaged and causing a issue? The stepper motor only has a knurled thing on it (if you did the upgrade or have a Delta+ or a standard tooth cog thing… (i.e. nothing moves in the way to block the path)… it’s possible that you didn’t press the release down hard enough? (especially if you did the upgrade kit, as the cap Flux supplied doesn’t let you press it down hard enough to completely freely push the filament through)… And it’s great to know that the load filament option works now when paused… much easier! :smiley:


#8

It seemed to me, no matter how hard I pushed the latch, I could not get the filament to push in. When I normally do a ‘load filament’ function before a print, it is easy for me to push the filament in when I have the latch pushed down before I hit the ‘load filament’ button. Doing it the way I described, because of the knurled thing on the stepper motor, it grabbed the filament and feed it in (slowly until I applied slight pressure to the build plate). i guess your mileage may vary. :slight_smile: (My Flux is the original with the upgrade kit installed).


#9

Yeah, same here. I replaced the button that was supplied though, as it is actually that which is stopping you pressing the lever down fully.

@Matfink made this model (which works perfectly) and now there is no resistance from that gear whatsoever as you can push the spring clamp thingy away fully :wink: