Camera rotated on Delta


iOS or Android app? For iOS, you need to join the Testflight program. For Anroid, the app is supposed to be in the beta section of the Android store.

Links and more info are in the 0.6.0 Flux Studio changelog, because everyone will naturally think to look there when looking for the app! :laughing: :stuck_out_tongue:


Now I just need to figure out the rotated camera.



Oh, that’s easy… turn your head 90 :stuck_out_tongue: :laughing:

I can’t say I’ve seen any settings that relate to the camera… and I don’t know if you can physically have the camera installed incorrectly (although I suspect not… the wires probably determine the positioning of the camera)… that might be something for a support ticket as those guys would know what side of things better.


If the upgrade kits ever ship there is a new camera included in the upgrade kit.


Can you use the camera button on the top right of the image in FLUX Studio to export it?


The image within fluxstudio is rotated 90 degrees counter clock wise, however the image saved out is the proper orientation (see below).

Is the a possibility to have an orientation preference in the fluxstudio software to fix my problem (so there need not be hardware fixes required)?



Edit: Disregard this post… restarted the printer and flux studio as suggested and it magically worked! :wink:

I can now add my name to the list of those afflicted with the soon to become infamous ‘must turn head to the the right to view’ camera syndrome. The cause? Installing the camera from the upgrade kit! Not the upgrade I was looking for! :laughing: And yes, I did choose the option to use the upgrade kit camera in the preferences…

Stock Delta Camera:

Upgrade Kit Camera:

Flux Delta Upgrade Experiences

There’s an option in FLUX Studio under File | Preferences | Machine | Machine List | to set “Upgrade Kits Camera” to “Enable” (presumably to take care of the 90-degree rotation) and “Upgrade Kits Extruder” to “Enable” (to take care of the change in mm/steps of the new design) that should be set once the upgrade is complete.

Didn’t seem to take until I shut down both the app and the printer. It now shows right-side-up in FLUX Studio, however.


Hm… I’ll try restarting them both then… the app restarted itself, but I haven’t restarted the printer. As I mentioned I’d already chosen the upgrade kit camera option, so was expecting it to work… but maybe it needs a little persuasion! :wink:

Edit: Yup, that (manual restart of both printer and app) fixed it! Thanks @darkgrue

Oh, but the export image (when you click the camera icon in the top right corner of the image) is still rotated… unless that has been fixed in a later version of flux studio… I’m still on 0.7.4. It also looks like the camera view in flux studio doesn’t show the full height of the image (when compared with the correctly rotated exported camera image).


Yeah, looks like the snapshot image is rotated. I just checked 0.7.6, and the camera preview in the app is righted, but clicking the camera image saves the image rotated 90 degrees clockwise.

Looks like they might have missed that. Hopefully it’ll get fixed in a future version?


I have upgraded my camera today and enabled it in the preferences. It is rotated 90 degrees clockwise as well. i dont know why. its rotated everywhere. doesnt matter if i am taking a look over the flux android app or on fluxstudio itself. even in the scanning mode…


With the Delta upgrade kit installed my camera is the right way up in latest flux studio but rotated right 90 deg in the iOS apps.


Yeah, I noticed the same when I used the iOS app the other day… but wasn’t so bothered because it was probably just that the app hadn’t been updated yet. Although really the printer firmware should handle any necessary rotations so that the end-devices don’t need fixing.


Have you changed anything in the settings except the upgrade kit enable on?


That and the Upgrade extruder setting.


Strange. I did exactly the same as you but my camera is still rotated…


Restart both flux studio and the printer… Mine was rotated until I rebooted them both… not sure which really needed it, but it was fine after that. You may also need to make sure you’re running a post 1.6.40 machine firmware, as the instructions keep mentioning 0.7.4 or later of flux studio, and 1.6.40 or later of the machine firmware.


I’ll second pfeerick’s reboot suggestion. Mine is fixed now after pc and flux rebooted.


I rebooted everything as well and its not turned anymore.


@BBUSTARD I can’t claim credit for the suggestion… someone else suggested that to me… so just sharing the love… er, helpful tips. :wink: Glad it fixed the problem for you guys also though! :smiley: