After software installation only a window with NW.JS shows up


#1

I had Flux Studio working on a different computer at one point. Now I can’t get the software to work on this computer. I get this:

What causes this, and how can I fix it?


#2

Updated to latest 0.4.1 and still have the same window…


#3

Did you resolve this because I just tried installing Flux Studio and I got the same thing. I going to try and uninstall and try again.


#4

Let it sit for a long time due to being busy in other areas. Came back and updated to latest 0.6.1. Uninstalled newer C++ and installed the older version.
Still the same old crap…

I have no idea why it works on my laptop and not my work desktop…

Any ideas @proclaim?

Thanks,
Jason


#5

I am still having this issue on two machines for over a month. Support has been pretty slow to respond. If @MarioSpeedwagon you find a solution, I would greatly appreciate it if you post it.

Thank you!


#6

I also have this issue. I hadn’t used my printer since I first got it on the early bird Kickstarter branch.
It was the first install of Flux Studio on Windows 10 Pro x64 build 14393.
I’ve done multiple reinstalls of the Flux Studio and Microsoft Visual C++ Redistributible x64 with full disk and registry cleanups in between. I’ve had no success in resolving this issue.


#7

@proclaim I still have this issue as well. My printer is useless without the software.


#8

I still have no solutions, nor responses from @proclaim or @simon or @jim. they seem to be more concerned with FluxDelta+ and using their deltas to robotically slap a printed face.


Absolutely nothing wrong with any of it, except for the fact I can’t get any attention to get the this issue addressed.

I kind of want to build a lifesize robotic slapper just to get some attention to such a critical issue as the software not working.


#9

Flux Studio is working OK on my PC. NW.js (previously known as node-webkit) https://nwjs.io/ . Would you try to install the stand alone node-webkit and test with Flux Studio.


#10

@goldensnake, what are you referring to by installing the node-webkit? The page for nw.js has a link with .dll files and a stand alone application with no install files. Should those files just be placed in a folder somewhere? Besides, the FLUX application would presumably only call up the nw.dll within its own installed program folder, yes?

PS, thanks for responding. No one else on the FLUX side seems to even know what to try.


#11

I think you should try to install it and copy any missing dll files to FS folder that how I should do. Good luck.


#12

I tried copying the entire folder into the Flux Studio folder but that did not work. I need to dig into it more.


#13

I’m sorry that you’re experiencing this issue. here’s what I think might be the cause

  1. permissions. the program doesn’t have enough permission to run, and create files on your computer. maybe try “run as administrator” ?
  2. temp folder might be crushed or not have write permission. when FLUX studio starts, it needs to create temp folder / files. (path name: /users/[user name]/AppData/local/temp). Feel free to delete everything in it and watch which folder /files it generates when you starts FLUX studio. If there’s nothing being generated in the temp folder, then there’s definately something wrong. If you did see files / folder in it, look for folders starts with “nw”.

very few people encounter your problem. I’ll see what else could be the cause.


#14

I have tried both steps with no luck. I understand that this is affecting a small portion of the user base but if you spent over $600 on a product that did not work, I am sure you would want it fixed. Also, this issue could the tip of the iceberg in the sense if there is a conflicting program, it may affect more people in the future.

That being said, I am happy to work with you on this. I am a developer so I do not mind complicated steps.


#15

@MarioSpeedwagon Did you have any luck with this? I have not.


#16

Consider me another user with the same issue…


#17

I have same problem, What can i try?


#18

I had to have @proclaim hop onto my PC to fix the issue. It appears something is interfering with the opening of the resource.pak file. He manually unpacked the file and changed the launch shortcut to read the folder. I do not know what he did so I cannot help directly. Also, when I installed the new version, the same problem appeared.

I ended up creating Windows 10 virtual machine on my server and running Flux Studio from there. I know that is not a very good solution but I got frustrated.

I think the problem is that I installed a VPN client that also uses nw.js and it changed the default running of nw.js apps. I have no idea what that would be but it is the only thing that makes sense to me. I have two machines with the exact same problem and the common element is the VPN client.


#19

The solution requires several steps:

  1. Find your installation folder (likely c:\Program Files\Flux)
  2. Copy FLUX_Studio.exe to your Desktop
  3. Create a new folder called “app”
  4. Open FLUX_Studio.exe with WinZip or 7zip (yeah, that sounds weird)
  5. Copy all files that are inside into your new “app” folder. File list should look like this:
  6. Delete the copy of FLUX_Studio.exe from the Desktop. This is no longer needed.
  7. Move the new “app” folder into the Flux folder (back to c:\Program Files\Flux)
  8. Start Flux by dragging the “app” folder onto the FLUX_Studio.exe icon:
  9. Done, although you will need to launch this way every time.

To make a shortcut for this, you can locate your current Flux Studio shortcut (likely on the Desktop). Right-click the icon and click Properties (typically last option). At the end of the Target text box, add a space, a quote, the word app, and another quote.

You should now have a direct shortcut that should work every time.

I have no idea why this is happening, and yes, you will need to redo this on every release. Enjoy!


#20

I owe you a beer, wine, coffee whatever your drink is. :beer: :wine_glass: :coffee: Thank you! I was looking at the wrong file. I was thinking it was the Resource.pak file. I don’t mind redoing the unzip if it gets it running. A bit of a pain but better than nothing.