Adding a heated bed - How do i adjust z-offset during calibration?


#1

Just like the title says I am trying to add a heated bed and i need to adjust the floor height. I bought a “Kossel Heatbed Round Alu MK3” off of ebay and a glass build plate that i attached with clips. I printed off some feet that i screwed onto the heater and it just sits on the original steel build plate. My new print surface is 25 mm higher than the original height.

I tried changing the “z_offset” in the expert settings to 25 but the print head still crashes into the glass plate… I took the heated bed off and tried the print again still with the 25mm offset enabled. The print head went all the way down to the original height during calibration and when it was ready to print then it finally applied the offset.

Does anyone know how to change the offset during calibration?

Here’s some pics. It is very much a work in progress, i am planning on printing a case for all the electricals once i finalized my design and so i just wanted to do a proof of concept test.

To control the temperature i am using an arduino nano and a thermistor. Here’s the github:

Thermistor taped to bed for testing. I’m going to use the gasket silicone in the background to permanently mount the thermistor.


#2

Just a suggestion, did you try the different Auto-Calibration options in the Preferences?


#3

I didn’t even know about Auto-Calibration. I just tried it, the tool head still slammed into the bed again and it didn’t adjust z-height. I tired with z-offset on and off and there was no affect.

Here’s the error message


#4

Edit to the post type --> I changed this into a “Feature Request” because this isn’t really an issue with the printer.

Could we please get the ability to adjust the z_offset during calibration?


#5

Seems like a really interesting mod, strange that offsets don’t work. Obvious question, but have you tried the current (stable) version of the software (v0.6.2)? Best of luck!